All users will need to merge their Minecraft Forum account with a new or existing Twitch account starting October 23rd. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 0

    posted a message on Constant server lag (hosting locally with jar)

    It seems the lag disappears for EVERYONE on the server when I connect using localhost instead of my external IP. Not sure why, but atleast there's no more lag. Thanks for the suggestions!

    Posted in: Server Support
  • 0

    posted a message on Constant server lag (hosting locally with jar)

    I'm using craftbukkit. I've hosted plenty of server on various versions of Minecraft since beta 1.8 and never had issues with lag

    Posted in: Server Support
  • 0

    posted a message on Constant server lag (hosting locally with jar)

    Everyone is having the lag, and I'm hosting on my own computer so I shouldn't have any connection lag. Also as i wrote i have 500Mbit download and upload speed. Not sure what an optimized server jar is. My friends are on an external network.

    Posted in: Server Support
  • 0

    posted a message on Constant server lag (hosting locally with jar)

    Specs:

    OS: Windows 10

    RAM: 16GB DDR3 1600MHz

    CPU: Intel i7-3770k @ 4.2GHz (w/ Corsair H45 liquid cooling)

    Video Card: GTX 780

    Internet Speed: 500Mbit/500Mbit


    I recently opened a local minecraft server to play with my friends. We've been 5-6 people on at the same time (at most).

    At the very beginning everything seemed fine, but after maybe the first 3-4 hours of playing the server started lagging a bit. Since then it has gotten worse.

    I downloaded a plugin to check TPS and it is always 19.5-20, even though the lag is unbearable. I have allocated 8GB of ram to the server (even though it never uses more than 1) and according to Windows' task manager my CPU is never on more than 50% load.


    The type of lag we're experiencing is entities move in a laggy way (practically teleport 2 blocks, pause, then teleport another 2 blocks and so forth). Also when firing arrows from a bow, about 0,5-1 sec passes between when you release the RMB and when the arrow fires. Also when breaking blocks it takes 0,5-1 sec before the block drops.


    At first i ran the server with just a simple

    java -Xmx8192M -Xmx1024M -jar craftbukkit-1.12.1.jar nogui
    PAUSE


    but after searching for fixes i added a few tags and ended up with this:

    java -server -d64 -Xmx8192M -Xms1024M -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:ParallelGCThreads=2 -XX:+AggressiveOpts -jar craftbukkit-1.12.1.jar nogui
    PAUSE


    I have not noticed any difference with all those tags though.


    I have tried moving the world to a vanilla (non-bukkit) server and it was still laggy. I have also deleted all of the region files created from exploring, keeping only the ones we've built things in.


    Any help is appreciated!

    Posted in: Server Support
  • 0

    posted a message on [1.5.2 / 1.5.1 / 1.4.7 / 1.3.2] Creating Mods - Modloader/Forge ~SCMowns [Src & Video]
    Quote from Alfihz

    Sir, I Enjoy watching your modding tutorials and others.. then i tried out modding.. the first thing we did was making the green gem.. i did what u said no error came up but when i started minecraft it doesnt show the green gem.. i mean there was no green gem at all ..

    Would you please help me?
    Tnx, Alfihz

    PS: I'm using MC1.4.6 and i know a lil bit about java programming since im studying it. :D


    In your ItemGreenGem class, do you have:" this.setCreativeTab(CreativeTabs.tabMaterials); " under maxStackSize?

    Because that (obviously) makes the item appear in the Material tab in creative.
    Posted in: Mapping and Modding Tutorials
  • 0

    posted a message on TEKKIT SERVER
    IGN: Januxii

    Love Tekkit / Technicpack <3
    Posted in: Minecraft Survival Servers (archive)
  • To post a comment, please or register a new account.